源设置错误导致依赖冲突

有天心血来潮,换了个源,把自己的mint发行版升级了一下。结果应用中心不好用了,不仅如此,再安装其他软件时,总是依赖错误:

maxiee@maxiee ~ $ sudo apt-get install software-center

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是

因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件

包尚未被创建或是它们已被从新到(Incoming)目录移出。

下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:

software-center : 依赖: ubuntu-sso-client-gtk 但是它将不会被安装

依赖: oneconf (>= 0.2.6) 但是它将不会被安装

推荐: update-notifier 但是它将不会被安装

推荐: xz-lzma 但是它将不会被安装

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

引用ubuntu wiki上的话:出現類似上面的問題,99%以上的可能 是你設置源時把源設錯了。

好吧,google 了一个Mint 14 的源换了以后,就没问题了!